The S2 and Apple Operating Systems

 I installed the hardware and software for the Native Instruments S2 onto my dell laptop.  Everything was working fine, but I knew that I really wanted to hook it up to my Mac.  It's a little more portable although it's a regular MacBook from 2009.  After trying to install Traktor on the Mac, it said that I needed operating system 10.6!!  I currently was using 10.5.8.  All of this is a little confusing to me - I then did a little research and found out about Snow Leopard and Lion.  What's wtih Mac's and these animals anyways?  I had to order Snow Leopard in the mail (they are sending me a DVD), and then I should be able to use my S2 with my Mac.  

Leave a comment

    Add comment